Tempat Berbagi Catatan dan Riset tentang Ilmu Jaringan Komputer, Tutorial Mikrotik, Cisco, GNS3, Linux, Windows serta Aplikasi Ujian Online

Cara Load Balancing Dual WAN di Mikrotik Metode PCC

Load Balancing (LB) adalah metode untuk berbagi beban trafik-data secara seimbang pada dua jalur internet atau lebih. Jadi teknik load balancing ini tidak menambah bandwidth menjadi 2x lipat atau beberapa kali lipat, akan tetapi LB hanya berbagi tugas agar modem-modem yang kita pakai dari isp dapat berbagi beban data secara seimbang sehingga tidak ada lagi overload pada salah satu modem sementara modem yang lain trafik datanya lengang atau bahkan tidak ada trafik-data. nggak bagus kan kalau seperti itu hehehe, makanya kita perlu teknik loadbalancing supaya performa jaringan menjadi lebih optimal, throughput lebih maksimal dan tidak ada lagi bandwidth yang tersia-siakan lagi.

cara load balancing ppc mikrotik


Di Mikrotik RouterOS ada banyak cara untuk membuat load balance dan kali ini kami akan sharing cara setting load balancing PCC di mikrotik dengan 2 konesi ISP. Untuk menyingkat waktu langsung saja kami berikan scriptnya :

## ====start code====

/ip address

add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1

add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2

add address=192.168.3.1/24 network=192.168.3.0 broadcast=192.168.3.255 interface=Local

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8

/ip firewall mangle

add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn

add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1

add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local

add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1

add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2

/ip route

add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

/ip firewall nat

add chain=srcnat out-interface=WAN1 action=masquerade

add chain=srcnat out-interface=WAN2 action=masquerade

## ====end code====

Script diatas ini anda copy ke notepad, kemudian anda sesuaikan dengan kebutuhan topologi anda.
setelah itu anda buka winbox, masuk ke dalam winbox, klik New terminal, kemudian paste.

Update: 28 Januari 2017

jika anda ingin menerapkan load balance PCC ini untuk hotspot, tambahkan rule ini pada firewall nat:

/ip firewall nat add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth


Update: 30 Januari 2017

Apabila anda berlangganan koneksi dengan kecepatan yang berbeda, misalnya modem pertama / WAN1 sebesar 10Mbps, kemudian modem kedua / WAN2 sebesar 20Mbps.
gunakan kode rule dibawah ini pada mangle PCC:

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

dari kode sini terlihat bahwa:
PCC 1 => new-connection-mark=WAN1_conn
PCC 2 => new-connection-mark=WAN2_conn
PCC 3 => new-connection-mark=WAN2_conn

Karna koneksi total di sisi WAN itu adalah 10+20, di kasih mangle PCC akan menjadi 10+(10+10), dan tentu saja di sisi client 10+20= 30mbps. OK dah semoga bermanfaat kawan!!!

Selanjutnya baca:

Cara Load Balancing Dual WAN di Mikrotik Metode PCC Rating: 4.5 Diposkan Oleh: Jawara Cloud

6 komentar:

  1. assalamualaikum,
    Gan mau tanya cara masukin yang updatan trkhir (30 Jan 2017) gmna ? masih newbie

    BalasHapus
    Balasan
    1. yg update 30 Jan 2017, ada script terpotong om, blm sempat edit lagi :)

      Hapus
    2. mohon di update dong om makasih (y)

      Hapus
    3. sudah di update lagi om, selamat mempraktekkan :)

      Hapus
  2. Numpang tanya gan, gimana caranya agar 2 ISP di pakai per kelompok IP, misalnya:
    P: 192.168.1.101 - 192.168.1.199 via ISP1
    IP: 192.168.1.200 - 192.168.1.250 via ISP2
    Dan redirect situs menggunakan web proxy.
    Sudah coba dari sumber lain tapi tidak bisa akrifkan web proxy (Jika digunakan semua client tidak bisa konek internet)
    Terima kasih

    BalasHapus
    Balasan
    1. utk settingan yg belum ada tutorialnya dsini, hubungi saya via WA 0822-3348-3221

      Hapus

Apabila ada pertanyaan dengan artikel ini mohon tinggalkan komentar anda pada form yg tersedia. Mimin akan menjawab saat tidak ada kesibukan :) Semoga Hari-hari anda senantiasa mendapatkan curahan cahaya kasih sayang Alloh SWT.